Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • James JosephJames
    Keymaster

    Hi,

    Share the following information.

    1. The AIS140 device’s configuration (Server configuration) from the device check what it is and post it exactly as it is.

    2. You referred to login packets “Point that out in both the logs you shared in this topic above” please. Where do you see login packet in above logs.

    Also as we have already discussed these issues earlier, I would suggest you to please share exact information as requested and to take this on a step by step manner to avoid assumptions and conclusions.

    The best way to troubleshoot is to first rule out the possibilities !

    That being said, this is not a Traccar issue based on our understanding!

    in reply to: Unable to disable or enable device using PHP API #286
    James JosephJames
    Keymaster

    Please share the part of code that you are calling this function as well!

    in reply to: Accept header missing #241
    James JosephJames
    Keymaster

    1. The error you shared “device access denied” has nothing to do with the headers, check your session and permissions for that!

    2. If you would like to include an header, you can always do so as shown in the example below ( I have added the “self::$jsonA” part.)

    public static function positions($sessionId){
    	$data = '';
    	return self::curl('/api/positions?'.$data,'GET',$sessionId,'',array(self::$jsonA));
    }
    • This reply was modified 5 months, 3 weeks ago by James JosephJames.
    • This reply was modified 5 months, 3 weeks ago by James JosephJames.
    in reply to: Accept header missing #236
    James JosephJames
    Keymaster

    Hi,

    Could you please share which function are you calling?

    If you could share both your code, and the api files code for the function you are calling it would help!

    • This reply was modified 5 months, 3 weeks ago by James JosephJames.
    in reply to: assignUserNotification #225
    James JosephJames
    Keymaster

    You do not need to worry about the error code! In the case of “permissions” the responseCode for success returned is 204

    in reply to: assignUserGeofence #224
    James JosephJames
    Keymaster

    Hi,

    What database are you using? and has anything been changed in the database or any customizations done?

    Based on the error, it is something to do with the database.

    in reply to: Geofence Create & Update #203
    James JosephJames
    Keymaster

    Hi,

    Try the following

    public static function geofenceCreate($sessionId,$name,$description,$area,$server){
    	
    	$id = '-1';
    	$attributes = '{}';
    
    	$data='{"id":"'.$id.'","name":"'.$name.'","description":"'.$description.'","area":"'.$area.'","attributes":'.$attributes.'}';
    
    	return self::curl('/api/geofences','POST',$sessionId,$data,array(self::$jsonC),$server);
    }
Viewing 7 posts - 1 through 7 (of 7 total)